fout: Dit is waarschijnlijk geen probleem met npm. Er is waarschijnlijk extra logoutput hierboven

In mijn project gebruik ik Angular6 voor de frontend. Wat ik nu probeer te doen, is mijn project dat zich op een externe server bevindt, op de eigenlijke server implementeren. Ik gebruik de opdracht npm run build -prodom eerst de frontend te bouwen. Maar ik kan mijn project niet bouwen omdat de volgende fout keer op keer optreedt,

npm ERR! code ELIFECYCLE
npm ERR! errno 134
npm ERR! [email protected] build: `ng build --prod --build-optimizer --aot`
npm ERR! Exit status 134
npm ERR!
npm ERR! Failed at the [email protected] build script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Indrajith.E\AppData\Roaming\npm-cache\_logs\2019-08-22T08_41_00_271Z-debug.log

Mijn foutenlogboek in het C:\Users\Indrajith.E\AppData\Roaming\npm-cache\_logs\2019-08-22T08_41_00_271Z-debug.logbestandspad bevat dezelfde foutdetails hierboven vermeld.

Hoe kan ik dit probleem oplossen?


Antwoord 1, autoriteit 100%

Verwijder je package-lock.jsonbestand en node_modulesmap.
Voer vervolgens npm cache opschonen uit

npm cache clean --force

doe
npm install

opnieuw en uitvoeren


Antwoord 2, autoriteit 33%

Eindelijk heb ik een oplossing voor dit probleem gevonden zonder npm opnieuw te installeren en ik post het omdat het in de toekomst iemand zal helpen,
Meestal treedt deze fout op. De javascript-heap is uit het geheugen verdwenen. Zoals de fout zelf zegt, is dit geen probleem met npm. Het enige wat we hoeven te doen is

in plaats van,

npm  run build -prod

breid het javascript-geheugen uit door te volgen,

node --max_old_space_size=4096 node_modules/@angular/cli/bin/ng build --prod

Antwoord 3, autoriteit 15%

Ik ben op Ubuntu 18.04. Ik heb dit probleem opgelost door de inotify max_user_watcheste verhogen met dit commando:

echo 65536 | sudo tee -a /proc/sys/fs/inotify/max_user_watches


Antwoord 4, autoriteit 8%

Ik ben nieuw met reageren… Nou, ik had dezelfde output:

Starting the development server...
events.js:196
      throw er; // Unhandled 'error' event
      ^
Error: ENOSPC: System limit for number of file watchers reached, watch '/opt/lampp/htdocs/react-tuto/public'
    at FSWatcher.<computed> (internal/fs/watchers.js:168:26)
    at Object.watch (fs.js:1351:34)
    at createFsWatchInstance (/opt/lampp/htdocs/react-tuto/node_modules/chokidar/lib/nodefs-handler.js:38:15)
    at setFsWatchListener (/opt/lampp/htdocs/react-tuto/node_modules/chokidar/lib/nodefs-handler.js:81:15)
    at FSWatcher.NodeFsHandler._watchWithNodeFs (/opt/lampp/htdocs/react-tuto/node_modules/chokidar/lib/nodefs-handler.js:233:14)
    at FSWatcher.NodeFsHandler._handleDir (/opt/lampp/htdocs/react-tuto/node_modules/chokidar/lib/nodefs-handler.js:429:19)
    at FSWatcher.<anonymous> (/opt/lampp/htdocs/react-tuto/node_modules/chokidar/lib/nodefs-handler.js:477:19)
    at FSWatcher.<anonymous> (/opt/lampp/htdocs/react-tuto/node_modules/chokidar/lib/nodefs-handler.js:482:16)
    at FSReqCallback.oncomplete (fs.js:165:5)
Emitted 'error' event on FSWatcher instance at:
    at FSWatcher._handleError (/opt/lampp/htdocs/react-tuto/node_modules/chokidar/index.js:260:10)
    at createFsWatchInstance (/opt/lampp/htdocs/react-tuto/node_modules/chokidar/lib/nodefs-handler.js:40:5)
    at setFsWatchListener (/opt/lampp/htdocs/react-tuto/node_modules/chokidar/lib/nodefs-handler.js:81:15)
    [... lines matching original stack trace ...]
    at FSReqCallback.oncomplete (fs.js:165:5) {
  errno: -28,
  syscall: 'watch',
  code: 'ENOSPC',
  path: '/opt/lampp/htdocs/react-tuto/public',
  filename: '/opt/lampp/htdocs/react-tuto/public'
}
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! [email protected] start: `react-scripts start`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the [email protected] start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! A complete log of this run can be found in:
npm ERR!     /home/paulo/.npm/_logs/2019-12-16T16_46_27_856Z-debug.log

Ik heb net geprobeerd:

sudo npm start

En het werkte.


Antwoord 5, autoriteit 8%

Ik heb al hetzelfde probleem . en ik repareer het met npm update& npm cache opschonen –force


Antwoord 6, autoriteit 8%

Verwijder node_modules

rm -r node_modules

pakketten opnieuw installeren

npm install

Antwoord 7, autoriteit 6%

Verwijder package-lock.jsonen wis npm cache met npm cache clear --force
en verwijder de hele node_modulesdirectory

Installeer of update pakketten ten slotte opnieuw met npm install/ npm update
U kunt ook nieuwe pakketten toevoegen met npm install <package-name>

Dit is voor mij opgelost.

Bedankt en veel plezier met coderen.


Antwoord 8, autoriteit 6%

Voor mij zat het probleem in firebase.json, de naam van de sitewas onjuist.


Antwoord 9, autoriteit 6%

Voor de mensen die niet werkten, ik heb twee dagen besteed aan het vinden van de oplossing en er was maar één commando dat werkte als een magie.

npm install -g live-server

en voer dan uit: npm start

het zal normaal beginnen. Je kunt alle details hier lezen https://www. npmjs.com/package/live-server


Antwoord 10, autoriteit 4%

Het verwijderen van package-lock.json deed het voor mij. Ik raad je aan om package-lock.json niet naar je repo te pushen, omdat ik uren heb verspild aan het installeren van npm met de package-lock.json in de map die me enorme fouten opleverde.


Antwoord 11, autoriteit 4%

Controleer of de poort waarop u uw app wilt uitvoeren, vrij is. Voor mij was dat het probleem.


Antwoord 12, autoriteit 4%

De volgende stappen lossen mijn probleem op:
Voeg “C:\Windows\System32\” toe aan uw systeempadvariabelen
Voer npm uit,
Voer npm start uit,
Voer npm uit,
en weer rennen
npm start
En het werkte??


Antwoord 13, autoriteit 4%

Voor mij probeerde ik een oude versie van bcrypt te installeren die niet in npm werd gevonden, ik heb zojuist package.json bewerkt en handmatig de nieuwste versie geplaatst en vervolgens npm installuitgevoerd en het werkte


Antwoord 14, autoriteit 4%

  1. verwijder eerst het bestand (project).
  2. vervolgens rm -rf \Users\Indrajith.E\AppData\Roaming\npm-cache_logs\2019-08-22T08_41_00_271Z-debug.log (dit is het bestand (log) dat een fout vertoont).
  3. maak uw project opnieuw, bijvoorbeeld:- npx create-react-app hello_world
  4. dan cd hello_world.
  5. dan start npm.

Ik had ook dezelfde fout, maar hopelijk heb ik na 1 dag aan deze fout te hebben besteed deze oplossing en het begon perfect en ik hoop ook dat dit ook voor jullie werkt…


Antwoord 15, autoriteit 2%

Beginfout. Zorg ervoor dat uw package.json-bestand correct is gecodeerd. Ik had:

"start": "index node.js"
instead of:
"start": "node index.js"

17

Verwijder uw package-lock.json-bestand en de map node_modules. Voer vervolgens npm cache opschonen uit

npm cache opschonen –force
doe npm installeren


Antwoord 16, autoriteit 2%

Verwijder de map node_module en voer het hieronder uit in de opdrachtregel

rm -rf node_modules
rm package-lock.json yarn.lock
npm cache clear --force
npm install

Als het nog steeds niet werkt, probeer het dan hieronder

npm install webpack --save

Antwoord 17, autoriteit 2%

Ik doe gewoon twee stappen:
eerst:

export METEOR_ALLOW_SUPERUSER=true;

seconde:

sudo systemctl stop bbb-html5

en tot slot:

npm start

LEAVE A REPLY

Please enter your comment!
Please enter your name here

Other episodes