anaconda/conda – installeer een specifieke pakketversie

Ik wil het ‘rope’-pakket in mijn huidige actieve omgeving installeren met conda. Momenteel zijn de volgende ‘touw’-versies beschikbaar:

(data_downloader)[email protected] ~/code/data_downloader $ conda search rope
Using Anaconda Cloud api site https://api.anaconda.org
Fetching package metadata: ....
cached-property              1.2.0                    py27_0  defaults        
                             1.2.0                    py34_0  defaults        
                             1.2.0                    py35_0  defaults        
                             1.3.0                    py27_0  defaults        
                             1.3.0                    py34_0  defaults        
                             1.3.0                    py35_0  defaults        
rope                         0.9.4                    py26_0  defaults        
                             0.9.4                    py27_0  defaults        
                             0.9.4                    py33_0  defaults        
                             0.9.4                    py34_0  defaults        
                             0.9.4                    py26_1  defaults        
                             0.9.4                    py27_1  defaults        
                             0.9.4                    py33_1  defaults        
                             0.9.4                    py34_1  defaults        
                          .  0.9.4                    py35_1  defaults        

Ik wil de volgende installeren:

                        1.3.0                    py35_0  defaults        

Ik heb geprobeerd allerlei permutaties van ‘Conda install’ die ik ben niet van plan om op te noemen, omdat geen van hen juist zijn.

Ik ben er ook niet zeker wat de py35_0 is (ik ben ervan uitgaande dat dit is de versie van de python waartegen het pakket is gebouwd?) En ik weet ook niet wat ‘defaults’ betekent?


Antwoord 1, Autoriteit 100%

Er is geen versie 1.3.0voor rope. 1.3.0verwijst naar het pakket cached-property. De hoogste beschikbare versie van rope0.9.4.

U kunt verschillende versies met conda install package=version. Maar in dit geval is er slechts één versie van rope, zodat u niet nodig dat doet.

De reden dat u de cached-propertyin deze lijst is, want het bevat de string "rope": “cached-p touw erty “

py35_0houdt in dat u python versie 3.5voor deze specifieke versie nodig. Als je alleen python3.4en het pakket is alleen voor versie 3.5je kunt het niet installeren met conda.

Ik ben niet helemaal zeker over de defaultsniet. Het bevat aanwijzingen dat dit pakket is binnen het standaard conda kanaal.


Antwoord 2, Autoriteit 156%

Om een ​​specifiek pakket te installeren:

conda install <pkg>=<version>

bijvoorbeeld:

conda install matplotlib=1.4.3

Antwoord 3, gezag 72%

Als een van deze karakters, ‘& gt;’, ‘& lt;’, ‘|’ of ‘*’ worden gebruikt, moeten een enkele of dubbele aanhalingstekens worden gebruikt

conda install [-y] package">=version"
conda install [-y] package'>=low_version, <=high_version'
conda install [-y] "package>=low_version, <high_version"
conda install -y torchvision">=0.3.0"
conda install  openpyxl'>=2.4.10,<=2.6.0'
conda install "openpyxl>=2.4.10,<3.0.0"

waar optie -y, – Ja niet om bevestiging.

Hier is een samenvatting:

Format         Sample Specification     Results
Exact          qtconsole==4.5.1         4.5.1
Fuzzy          qtconsole=4.5            4.5.0, 4.5.1, ..., etc.
>=, >, <, <=  "qtconsole>=4.5"          4.5.0 or higher
               qtconsole"<4.6"          less than 4.6.0
OR            "qtconsole=4.5.1|4.5.2"   4.5.1, 4.5.2
AND           "qtconsole>=4.3.1,<4.6"   4.3.1 or higher but less than 4.6.0

Kramer van het bovenstaande informatie-tegoed aan Conda Cheat Sheet

Getest op Conda 4.7.12

Other episodes